Get in touch
Back
Degraded

Testing the reports

Started 20 Sep at 11:01am BST, resolved 20 Sep at 11:04am BST.

Resolved

We have resolved all issues, yay!

Posted 20 Sep at 11:04am BST.
Created

This is a test of the reports and the subscription functionality.

Posted 20 Sep at 11:01am BST.